Boards < Bugs & Suggestions < Bugs < Arena tie counted as loss (resolved)

Boards

  • Sumatra_Echo
  • User
  • Posts: 516

Posted at 2015-09-16 12:20:17 — Link

This has happened to me twice recently, where a battle ended with both pets' health reduced to zero, but the battle counted as a loss for me. I also tied two battles with this pet shortly before taking this screenshot, so the problem doesn't appear every time. Not sure what triggers it. 



  • Sylviianel
  • User
  • Posts: 791

Posted at 2015-09-16 13:10:14 — Link

I've experienced this as well; I know occasionally in the past, I haven't experienced it lately so I don't know if it's been fixed or if I've just been lucky, it would happen in explore too. I believe an explanation was given for that involving an error with pets with regen? I may just be misremembering though. In any case, yes, this bug is more than an isolated incident on one account.


  • Angel
  • Game Developer
  • Posts: 2,972

Posted at 2015-09-20 00:30:56 — Link

Thank you for reporting. Yes, we have this issue since the very start, and we weren't able to get rid of it yet. Actually the winner has a more than 0 hitpoints but due to rounding this is not visible. So it's just a visual bug and not something with logic; the battle result itself is correct. Sylviianel is right about the cause of this. This may happen with all of the skills that involve percentile hitpoints changes (like regeneration, napalm, poison). 

Sorry for the inconvenience.



« Prev | 1 | Next »

Xsolla is an authorized global distributor of BeastKeeper
Xsolla